文华 wh6/wh7/wh8 AO 动量震荡指标编写方法 [复制链接]

    autojiaoyi.com 发表于 2019-10-26 ・113 次阅读 副图指标 查看全部 使用道具 举报 回复

    文华 wh6/wh7/wh8 AO 动量震荡指标编写方法

    AO动量震荡指标.jpg
    AO 动量震荡指标形成的起因:由于价格是市场中最后发生变化的因素,先于价格发生变化的是动量,而先于动量发生变化的是当前的动量速度,再先于动量速度发生变化的是成交量,然而比成交量还要领先的变化就是我们所有投资者对市场中做出的决定。
    
    动量震荡指标(AO) 算法:
    //5根价格线的中点的移动平均线值减去34根价格线的中点的移动平均线值得来的,其中中点=(最高价+最低价)/2。
    注:
    //1、原理形成的过程是这样的:决策→成交量→动量速度→动量→价格;
    //2、AC是通过将一系列所得结果组成柱状图能准确发现当前动量的变化,由一根零轴和一些红柱绿柱组成;
    //3、属性为副图指标;
    //4、指标适用软件:wh6/wh7/wh8。
    
    源码如下:
    Y:=(HIGH+LOW)/2;
    AO:=MA(Y,5)-MA(Y,34);
    AO1:=REF(AO,1);
    STICKLINE(AO>AO1,0,AO,COLORRED,0);
    STICKLINE(AO<AO1,0,AO,COLORYELLOW,0);
    S1:=CROSS(0,AO);
    DRAWICON(S1,AO,5),ALIGN0;
    DRAWTEXT(S1,AO,'S'),COLORWHITE;
    S2:=AO<0 AND REF(AO,1)>REF(AO,2) AND AO<REF(AO,1);
    DRAWTEXT(S2,AO,'S'),COLORWHITE;
    SCOUNT:=BARSLAST(AO<0);//上一次AO>0后到现在的周期数;
    SD:=HHV(AO,SCOUNT);//求上面周期的最大AO;
    SCOUNTD:=HHVBARS(AO,SCOUNT);//求最大值到现在的周期数;
    S3:=AO>0 AND REF(AO,1)>REF(AO,2) AND AO<REF(AO,1);//满足峰的条件;
    S31:=COUNT(S3,SCOUNTD);//满足上面条件的次数;
    DRAWTEXT(S31>=2 AND S3,AO,'S'),COLORWHITE;
    B1:=CROSS(AO,0);
    DRAWTEXT(B1,AO,'B'),COLORWHITE;
    B2:=AO>0 AND REF(AO,1)<REF(AO,2) AND AO>REF(AO,1);
    DRAWTEXT(B2,AO,'B'),COLORWHITE;
    BCOUNT:=BARSLAST(AO>0);//上一次AO>0后到现在的周期数;
    BD:=LLV(AO,BCOUNT);//求上面周期的最小AO;
    BCOUNTD:=LLVBARS(AO,BCOUNT);//求最小值到现在的周期数;
    B3:=AO<0 AND REF(AO,1)<REF(AO,2) AND AO>REF(AO,1);//满足峰的条件;
    B31:=COUNT(B3,BCOUNTD);//满足上面条件的次数;
    DRAWTEXT(B31>=2 AND B3,AO,'B'),COLORWHITE;
    A-FUTU-560.zip (788 Bytes, 下载次数: 1)
    热帖

    全部评论/0 条

    本版积分规则

    发布新内容
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表