文华高低点策略方法:SAR 高低点确认方法 [复制链接]

    autojiaoyi.com 发表于 2019-10-24 ・144 次阅读 K线附属指标 查看全部 使用道具 举报 回复

    文华高低点策略方法:SAR 高低点确认方法

    SAR552.jpg
    SAR指标又叫抛物线指标或停损转向操作点指标,其全称叫“Stop and Reverse,缩写SAR”,是由美国技术分析大师威尔斯-威尔德(Wells Wilder)所创造的,是一种简单易学、比较准确的中短期技术分析工具。
    策略原理:
    //主要是通过SAR 绿转红或者红转绿之后再创新高或者新低,来编写策略方法。
    //SAR绿转红,同时满足k线高点创M周期新高,定义为高点;
    //SAR红转绿,同时满足k线低点创M周期新低,定义为低点;
    //高点和低点进行连线;
    
     源码:
    //SAR 源码指标,也包含未来函数 BACKSET,只可作为看盘来使用,无法实现自动化交易。
    STEP1:=2/100;
    MVALUE1:=20/100;
    SARLINE:SAR(4,STEP1,MVALUE1),NODRAW;
    IF(SARLINE>0,SARLINE,NULL),COLORRED,NOTEXT,CIRCLEDOT;
    IF(SARLINE<0,-SARLINE,NULL),COLORCYAN,NOTEXT,CIRCLEDOT;
    //定义M周期,可以任意修改
    M:=20;
    CON:=H>HV(H,M)&&SARLINE>0;
    CNX:=REF(CON,1)&&H<REF(H,1);
    NN:BARSLAST(CNX)+1;
    COM:=L<LV(L,M)&&SARLINE<0;
    CMX:=REF(COM,1)&&L>REF(L,1);
    MM:BARSLAST(CMX)+1;
    DRAWLINE3(CNX&&REF(EXIST(CNX,NN),1),REF(L,MM),MM,CMX&&
    REF(EXIST(CMX,MM),1),REF(H,NN),NN,0),COLORRED,LINETHICK3;
    DRAWLINE3(CMX&&REF(EXIST(CMX,MM),1),REF(H,NN),NN,CNX&&
    REF(EXIST(CNX,NN),1),REF(L,MM),MM,0),COLORGREEN,LINETHICK3;
    //倒数第二条画线
    MBV:=MAX(MM,NN);
    NBV:=MIN(MM,NN);
    ADM1:=BACKSET(ISLASTBAR&&MM=MBV,MBV+1);
    ADN1:=BACKSET(ISLASTBAR&&MM=MBV,NBV+1);
    DRAWLINE1(CROSS(ADM1=1,0.5),L,CROSS(ADN1=1,0.5),H,0),COLORRED,LINETHICK3;
    ADM2:=BACKSET(ISLASTBAR&&NN=MBV,MBV+1);
    ADN2:=BACKSET(ISLASTBAR&&NN=MBV,NBV+1);
    DRAWLINE1(CROSS(ADM2=1,0.5),H,CROSS(ADN2=1,0.5),L,0),COLORGREEN,LINETHICK3;
    //最后一条画线
    DRAWLINE3(ISLASTBAR&&H<REF(H,NBV)&&NBV=NN,L,0,1,REF(H,NN),NN,0),COLORGREEN,LINETHICK3;
    DRAWLINE3(ISLASTBAR&&L>REF(L,NBV)&&NBV=MM,H,0,1,REF(L,MM),MM,0),COLORRED,LINETHICK3;
    A-ZHUTU-552.zip (853 Bytes, 下载次数: 5)
    热帖

    全部评论/0 条

    本版积分规则

    发布新内容
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表