文华高低点策略方法:BOLL通道高低点判定方法 [复制链接]

    autojiaoyi.com 发表于 2019-10-24 ・127 次阅读 副图指标 查看全部 使用道具 举报 回复

    文华高低点策略方法:BOLL通道高低点判定方法

    551.jpg
    //主要依托 BOLL 通道指标,该指标在图形上画出三条线,其中上下两条线可以分别看成是股价的压力线和支撑线,而在两条线之间还有一条股价平均线,布林线指标的参数最好设为20。
    //一般来说,股价会运行在压力线和支撑线所形成的通道中,所以本方法的目的是通过压力线和支撑线,来确定通道高低点。
    策略原理:
    //最高价上穿上轨,取上穿之后的高点;
    //最低价下穿下轨,取下穿之后的低点;
    //进行连线
    
    源码:
    //源码中包含未来函数,只可作为看盘功能来使用。
    MID:MA(CLOSE,26);
    TMP2:=STD(CLOSE,26);
    TOP:MID+2*TMP2;
    BOTTOM:MID-2*TMP2;
    N:=BARSLAST(CROSSDOWN(L,BOTTOM))+1;
    M:=BARSLAST(CROSS(H,TOP))+1;
    LL:=IF(L<BOTTOM,L,100000);
    HH:=IF(H>TOP,H,0);
    LX:=BACKSET(M=1&&REF(EXIST(N=1,M),1),REF(LLVBARS(LL,M),1)+2);
    HX:=BACKSET(N=1&&REF(EXIST(M=1,N),1),REF(HHVBARS(HH,N),1)+2);
    DRAWLINE1(CROSS(LX=1,0.5),L,CROSS(HX=1,0.5),H,0),LINETHICK3,COLORRED;
    DRAWLINE1(CROSS(HX=1,0.5),H,CROSS(LX=1,0.5),L,0),LINETHICK3,COLORGREEN;
    A-ZHUTU-551.zip (605 Bytes, 下载次数: 1)
    热帖

    全部评论/0 条

    本版积分规则

    发布新内容
    加入收藏 我要分享
    分享到论坛或者博客

    复制
    热门指标策略
    快速回复 返回顶部 返回列表